ZuluNetTools

Руководство программиста

Библиотека компонентов для автоматизированных расчетов инженерных сетей.

Данная версия справочной системы от 28-10-2024

Библиотеки

  • ZuluComNetOcx (ZuluNetTools 2021)

Компоненты

  • ZCNNetworkCtrl

  • ZCNOutputCtrl

  • ZCNPiezoCtrl

  • ZCNTaskDrainCtrl

  • ZCNTaskGazCtrl

  • ZCNTaskHydroCtrl

  • ZCNTaskSteamCtrl

  • ZCNTaskThermoCtrl

  • ZCNTaskWinCtrl

Объекты

  • IZCNElemIDs

  • IZCNError

  • IZCNErrors

  • IZCNPumpDef

  • IZCNTGraphRec

  • ZCNNetwork

  • ZCNTaskDrain

  • ZCNTaskGaz

  • ZCNTaskHydro

  • ZCNTaskSteam

  • ZCNTaskThermo

Константы

  • zcnCalcStatus

  • zcnNetworkType

  • zcnTaskCode

  • zcnTaskType

Коды ошибок

  • ZuluDrain

  • ZuluGaz

  • ZuluHydro

  • ZuluSteam

  • ZuluThermo


Библиотеки

  • ZuluNetTools 2021

    ZuluComNetOcx (ZuluNetTools 2021) - библиотека компонентов для использования инженерных расчётов в пользовательских приложениях.


ZuluNetTools 2021

ZuluComNetOcx (ZuluNetTools 2021) - библиотека компонентов для использования инженерных расчётов в пользовательских приложениях.

Регистрационная информация:

Полное имя:

ZuluNetTools 2021

Короткое имя:

ZuluComNetOcx

Модуль:

ZuluComNetOcx.dll

LIBID:

{12507500-11DD-4DDC-AFDA-3007DB025F4D}

Список объектов:

Компоненты

Объекты

Константы

ZCNNetworkCtrl

ZCNOutputCtrl

ZCNPiezoCtrl

ZCNTaskDrainCtrl

ZCNTaskGazCtrl

ZCNTaskHydroCtrl

ZCNTaskSteamCtrl

ZCNTaskThermoCtrl

ZCNTaskWinCtrl

IZCNElemIDs

IZCNError

IZCNErrors

IZCNPumpDef

IZCNTGraphRec

ZCNNetwork

ZCNTaskDrain

ZCNTaskGaz

ZCNTaskHydro

ZCNTaskSteam

ZCNTaskThermo

zcnCalcStatus

zcnNetworkType

zcnTaskCode

zcnTaskType


Компоненты

  • ZCNNetworkCtrl Control

    Элемент ZCNNetworkCtrl представляет модель инженерной сети (тепловой, водопроводной, газовой и так далее), участвующей в расчетах. Данный элемент предназначен для размещения в качестве визуального компонента на форме в режиме design-time, ему соответствует объект ZCNNetwork, который можно создавать в режиме run-time без использования форм.

  • ZCNOutputCtrl Control

    Элемент ZCNOutputCtrl представляет окно сообщений ZuluGIS, служащее для протоколирования хода расчетов.

  • ZCNPiezoCtrl Control

    Элемент ZCNPiezoCtrl представляет собой окно пьезометрического графика.

  • ZCNTaskDrainCtrl Control

    Элемент ZCNTaskDrainCtrl представляет набор расчетов тепловых сетей ZuluDrain.

  • ZCNTaskGazCtrl control

    Элемент ZCNTaskGazCtrl представляет набор расчетов газовых сетей ZuluGaz.

  • ZCNTaskHydroCtrl Control

    Элемент ZCNTaskHydroCtrl представляет набор расчетов тепловых сетей ZuluHydro.

  • ZCNTaskSteamCtrl Control

    Элемент ZCNTaskSteamCtrl представляет набор расчетов паровых сетей ZuluSteam.

  • ZCNTaskThermoCtrl Control

    Элемент ZCNTaskThermoCtrl представляет набор расчетов тепловых сетей ZuluThermo.

  • ZCNTaskWinCtrl Control

    Элемент ZCNTaskWinCtrl представляет собой окно расчетов. В зависимости от указываемого кода расчетов в окно будет внедрено панель расчетов ZuluThermo, ZuluHydro, ZuluSteam или ZuluGaz.


ZCNNetworkCtrl Control

Элемент ZCNNetworkCtrl представляет модель инженерной сети (тепловой, водопроводной, газовой и так далее), участвующей в расчетах. Данный элемент предназначен для размещения в качестве визуального компонента на форме в режиме design-time, ему соответствует объект ZCNNetwork, который можно создавать в режиме run-time без использования форм.

Инженерная сеть создается либо использованием метода CreateNetwork и последующем заполнением ее с помощью методов AddObject и SetAttrValue, либо загружается уже существующая сеть в виде слоя ZuluGIS с помощью метода OpenNetwork.

Свойства

Методы

События

NetType

AboutBox

AddObject

AddPumpDef

Clear

CreateNetwork

GetAttrValue

GetProcessData

OpenNetwork

SetAttrValue


ZCNOutputCtrl Control

Элемент ZCNOutputCtrl представляет окно сообщений ZuluGIS, служащее для протоколирования хода расчетов.

Свойства и методы:

Свойства

Методы

События

Appearance

BorderStyle

Enabled

hWnd

AboutBox


ZCNPiezoCtrl Control

Элемент ZCNPiezoCtrl представляет собой окно пьезометрического графика.

Свойства и методы:

Свойства

Методы

События

Appearance

BorderStyle

Enabled

hWnd

Network

NetworkCtrlName

Path

AboutBox


Path property

Возвращает коллекцию элементов IZCNElemIDs, задающих путь, по которому строится пьезометрический график.

Применяется к:

ZCNPiezoCtrl

Синтаксис:

Visual Basic:

Property Path As IZCNElemIDs

Описание:

Путь, задаваемый свойством Path состоит из последовательности узлов и участков сети в виде <узел><участок><узел><участок><узел>. Путь должен начинаться и заканчиваться узлом, между ключами узлов должны следовать ключи участков.


ZCNTaskDrainCtrl Control

Элемент ZCNTaskDrainCtrl представляет набор расчетов тепловых сетей ZuluDrain.

Элемент предназначен для размещения на форме в режиме design-time. Соответствующий ему объект ZCNTaskDrain, реализующий ту же функциональность, предназначен для создания и управления в режиме run-time.

Свойства и методы:

Свойства

Методы

События

CalcStatus

Errors

Network

NetworkCtrlName

OutputCtrlName

Sources

AboutBox

Cancel

Run

SetOutput

OnCalcFinish


ZCNTaskGazCtrl control

Элемент ZCNTaskGazCtrl представляет набор расчетов газовых сетей ZuluGaz.

Элемент предназначен для размещения на форме в режиме design-time. Соответствующий ему объект ZCNTaskGaz, реализующий ту же функциональность, предназначен для создания и управления в режиме run-time.

Свойства и методы:

Свойства

Методы

События

CalcStatus

Errors

Network

NetworkCtrlName

OutputCtrlName

Sources

AboutBox

Cancel

Run

SetOutput

OnCalcFinish


ZCNTaskHydroCtrl Control

Элемент ZCNTaskHydroCtrl представляет набор расчетов тепловых сетей ZuluHydro.

Элемент предназначен для размещения на форме в режиме design-time. Соответствующий ему объект ZCNTaskHydro, реализующий ту же функциональность, предназначен для создания и управления в режиме run-time.

Свойства и методы:

Свойства

Методы

События

CalcStatus

Errors

LogMessages

Network

NetworkCtrlName

OutputCtrlName

PoverkaNotFixed

Sources

AboutBox

Cancel

ConstructGetCriterium

ConstructGetMinD

ConstructGetStartID

ConstructSetCriterium

ConstructSetMinD

ConstructSetStartID

GetStepNodeValue

GetStepPipeValue

ReserveAddColorInterval

ReserveRunStep

ReserveSetHmin

ReserveSetOutputLayer

ReserveSetStep

ReserveStartStepCalc

ReserveStopStepCalc

Run

RunStep

SetMinPipeLength

SetOutput

SetSource

SetStepNodeValue

SetStepPipeValue

StartStepCalc

StopStepCalc

OnCalcFinish


ZCNTaskSteamCtrl Control

Элемент ZCNTaskSteamCtrl представляет набор расчетов паровых сетей ZuluSteam.

Элемент предназначен для размещения на форме в режиме design-time. Соответствующий ему объект ZCNTaskSteam, реализующий ту же функциональность предназначен для создания и управления в режиме run-time.

Свойства и методы:

Свойства

Методы

События

CalcStatus

Errors

Network

NetworkCtrlName

OutputCtrlName

Sources

AboutBox

Cancel

Run

SetOutput

OnCalcFinish


ZCNTaskThermoCtrl Control

Элемент ZCNTaskThermoCtrl представляет набор расчетов тепловых сетей ZuluThermo.

Элемент предназначен для размещения на форме в режиме design-time. Соответствующий ему объект ZCNTaskThermo, реализующий ту же функциональность предназначен для создания и управления в режиме run-time.

Свойства и методы:

Свойства

Методы

События

CalcStatus

Errors

MaxGot

MinDShb

MinDSoplo

NaladkaThermoLoss

NaladkaUseGVS

NaladkaUseLeaks

NaladkaUseSoplo

Network

NetworkCtrlName

OutputCtrlName

PoverkaCalcRo

PoverkaSummerMode

PoverkaThermoLoss

PoverkaUseFromNaladka

PoverkaUseLeaks

RoObr

RoPod

RunTaskMode

Sources

TGraphNaporFlag

TGraphTPolka

TGraphTSrezka

AboutBox

Cancel

ConstructGetStartID

ConstructSetStartID

Run

SetOutput

TGraphGetPotrebID

TGraphGetRecord

TGraphGetRecordCount

TGraphSetPotrebID

OnCalcFinish


ZCNTaskWinCtrl Control

Элемент ZCNTaskWinCtrl представляет собой окно расчетов. В зависимости от указываемого кода расчетов в окно будет внедрено панель расчетов ZuluThermo, ZuluHydro, ZuluSteam или ZuluGaz.

Тип расчетов, т.е. какую именно панель расчетов должен отображать элемент, задается свойством TaskType.

Свойства и методы:

Свойства

Методы

События

Appearance

BorderStyle

EnableClose

Enabled

hWnd

Network

NetworkCtrlName

OutputCtrlName

TaskType

AboutBox

SetOutput

CloseButton


Appearance property

Задает общий вид интерфейса компонента. Влияет на внешний вид рамки компонента.

Применяется к:

ZCNOutputCtrl,

ZCNPiezoCtrl,

ZCNTaskWinCtrl

Синтаксис:

Visual Basic:

Property Appearance As Integer

Описание:

Свойство Appearance может принимать следующие значения:

Значение

Описание

0

«плоский» (flat) вид

1

«объемный» (3D) вид

В случае, если свойство BorderStyle установлено в значение 1, то свойство Appearance влияет на внешний вид рамки компонента: 1 - объемная рамка, 0 - простая черная рамка.


BorderStyle property

Задает стиль рамки компонента.

Применяется к:

ZCNOutputCtrl,

ZCNPiezoCtrl,

ZCNTaskWinCtrl

Синтаксис:

Visual Basic:

Property BorderStyle As Integer

Описание:

Свойство BorderStyle может принимать следующие значения:

Значение

Описание

0

нет рамки

1

простая рамка (зависит от Appearance)

2

тонкая серая рамка


EnableClose property

Задает наличие кнопки «Закрыть» у панели расчетов.

Применяется к:

ZCNTaskWinCtrl

Синтаксис:

Visual Basic:

Property EnableClose As Boolean

Описание:

Если свойство имеет значение True, то панель расчетов будет иметь кнопку «Закрыть». По нажатию на кнопку элемент будет вызывать событие CloseButton.


Enabled property

Разрешает/запрещает реагирование компонента на события пользовательского интерфейса.

Применяется к:

ZCNOutputCtrl,

ZCNPiezoCtrl,

ZCNTaskWinCtrl

Синтаксис:

Visual Basic:

Property Enabled As Boolean


hWnd property

Возвращает дескриптор (HWND) окна компонента в виде числа Long.

Применяется к:

ZCNOutputCtrl,

ZCNPiezoCtrl,

ZCNTaskWinCtrl

Синтаксис:

Visual Basic:

Property hWnd As Long

read-only


CloseButton event

Возникает при нажатии кнопки «Закрыть» панели расчетов.

Применяется к:

ZCNTaskWinCtrl

Синтаксис:

Visual Basic:

Event CloseButton()


TaskType property

Задает тип инженерных расчетов, панель которых будет внедрена в окно элемента. Возможные значения определяются константами zcnTaskType.

Применяется к:

ZCNTaskWinCtrl

Синтаксис:

Visual Basic:

Property TaskType As Integer

Описание:

Обычно свойство TaskType задается в design-time.


Объекты

  • IZCNElemIDs object

    Объект для хранения списка номеров или числовых идентификаторов

  • IZCNElemIDs Object

    Коллекция ключей (ID) элементов сети. Используется в свойствах Sources, Path.

  • IZCNError Object

    Объект IZCNError содержит информацию об ошибке или сообщении, возникшим при выполнении расчетов. Является образующим элементом коллекции IZCNErrors.

  • IZCNErrors Object

    Коллекция объектов типа IZCNError, представляющая список ошибок и сообщений при выполнении расчетов. Входит как свойство Errors в объекты ZCNTaskThermoCtrl (ZCNTaskThermo), ZCNTaskHydroCtrl (ZCNTaskHydro) и др.

  • IZCNProcessData object

    Объект для работы со списком обработчиков данных слоя инженерных сетей

  • ZCNPumpDef Object

    Объект IZCNPumpDef описывает насос, используемый в расчетах тепловых и водопроводных сетей. Объект создается при вызове метода ZCNNetwork.AddPumpDef или ZCNNetworkCtrl.AddPumpDef

  • IZCNTGraphRec Object

    Объект IZCNTGraphRec представляет запись из таблицы, являющейся результатом расчета температурного графика тепловой сети. Возвращается методом ZCNTaskThermo.TGraphGetRecord (ZCNTaskThermoCtrl.TGraphGetRecord).

  • ZCNNetwork Object

    Объект ZCNNetwork представляет модель инженерной сети (тепловой, водопроводной, газовой и т.д.), участвующей в расчетах. Ему соответствует элемент ZCNNetworkCtrl, который можно размещать в качестве визуального компонента на форме в режиме design-time.

  • ZCNTaskDrain Object

    Объект ZCNTaskDrain представляет расчеты ZuluDrain. Ему соответствует элемент ZCNTaskDrainCtrl, который можно размещать в качестве визуального компонента на форме в режиме design-time.

  • ZCNTaskGaz Object

    Объект ZCNTaskGaz представляет расчеты ZuluGaz. Ему соответствует элемент ZCNTaskGazCtrl, который можно размещать в качестве визуального компонента на форме в режиме design-time.

  • ZCNTaskHydro Object

    Объект ZCNTaskHydro представляет расчеты ZuluHydro. Ему соответствует элемент ZCNTaskHydroCtrl, который можно размещать в качестве визуального компонента на форме в режиме design-time.

  • ZCNTaskSteam Object

    Объект ZCNTaskSteam представляет расчеты ZuluSteam. Ему соответствует элемент ZCNTaskSteamCtrl, который можно размещать в качестве визуального компонента на форме в режиме design-time.

  • ZCNNetwork Object

    Объект ZCNTaskThermo представляет расчеты ZuluThermo. Ему соответствует элемент ZCNTaskThermoCtrl, который можно размещать в качестве визуального компонента на форме в режиме design-time.


IZCNElemIDs object

Объект для хранения списка номеров или числовых идентификаторов

Входит в состав библиотеки ZuluNetTools 2021.

Свойства и методы:

Свойства

Методы

Count

Item

Add

Clear


Add method (IZCNElemIDs)

Добавляет элемент в коллекцию ключей IZCNElemIDs.

Применяется к:

IZCNElemIDs

Синтаксис:

Visual Basic:

Function Add(ID As Long) As Long

Описание:

Метод добавляет элемент в коллекцию и возвращает индекс нового элемента.


Clear method (IZCNElemIDs)

Очищает коллекцию ключей IZCNElemIDs.

Применяется к:

IZCNElemIDs

Синтаксис:

Visual Basic:

Sub Clear()


Count property (IZCNElemIDs)

Возвращает число элементов в коллекции ключей IZCNElemIDs.

Применяется к:

IZCNElemIDs

Синтаксис:

Visual Basic:

Property Count As Long

read-only


Item property (IZCNElemIDs)

Возвращает элемент из коллекции ключей IZCNElemIDs по индексу.

Применяется к:

IZCNElemIDs

Синтаксис:

Visual Basic:

Property Item(Index As Long) As Long

read only

Index - индекс в списке значений (нумерация с нуля)

Описание:


IZCNElemIDs Object

Коллекция ключей (ID) элементов сети. Используется в свойствах Sources, Path.

Свойства и методы

Свойства

Методы

Count

Item

Add

Clear


IZCNError Object

Объект IZCNError содержит информацию об ошибке или сообщении, возникшим при выполнении расчетов. Является образующим элементом коллекции IZCNErrors.

Свойства:

Свойства

Code

Name

Key

Param1

Param2

Text

Type


Code property (IZCNError)

Возвращает код ошибки или другого сообщения.

Применяется к:

IZCNError

Синтаксис:

Visual Basic:

Property Code As Long

read-only


Name property (IZCNError)

Возвращает имя поля или объекта, к которому относится данная ошибка или сообщение.

Применяется к:

IZCNError

Синтаксис:

Visual Basic:

Property Name As String

read-only


Key property (IZCNError)

Возвращает ключ (ID) элемента сети, к которому относится данная ошибка или сообщение.

Применяется к:

IZCNError

Синтаксис:

Visual Basic:

Property Key As Long

read-only


Text property (IZCNError)

Возвращает значение дополнительного параметра ошибки.

Применяется к:

IZCNError

Синтаксис:

Visual Basic:

Property Param1 As Double

read-only


Param2 property (IZCNError)

Возвращает значение дополнительного параметра ошибки.

Применяется к:

IZCNError

Синтаксис:

Visual Basic:

Property Param2 As Double

read-only


Text property (IZCNError)

Возвращает текст сообщения.

Применяется к:

IZCNError

Синтаксис:

Visual Basic:

Property Text As String

read-only


Type property (IZCNError)

Возвращает идентификатор типа элементов сети (участок, источник, узел и прочие), к которому относится данная ошибка или сообщение.

Применяется к:

IZCNError

Синтаксис:

Visual Basic:

Property Type As Long

read-only


IZCNErrors Object

Коллекция объектов типа IZCNError, представляющая список ошибок и сообщений при выполнении расчетов. Входит как свойство Errors в объекты ZCNTaskThermoCtrl (ZCNTaskThermo), ZCNTaskHydroCtrl (ZCNTaskHydro) и др.

Свойства:

Свойства

Count

Item


Count property (IZCNErrors)

Возвращает число элементов в коллекции IZCNErrors.

Применяется к:

IZCNErrors

Синтаксис:

Visual Basic:

Property Count As Long

read-only


Item property (IZCNErrors)

Возвращает элемент коллекции IZCNErrors по индексу.

Применяется к:

IZCNErrors

Синтаксис:

Visual Basic:

Property Item(Index As Long) As IZCNError

read-only


IZCNProcessData object

Объект для работы со списком обработчиков данных слоя инженерных сетей

Входит в состав библиотеки ZuluNetTools 2021.

Свойства и методы:

Свойства

Методы

Count

Add

GetNameByIndex

GetQuery

GetRunType

GetTasks

Save

SetQuery

SetRunType

SetTasks


Add method (IZCNProcessData)

Добавляет новый обработчик данных с заданным именем в список обработчиков данных

Применяется к:

IZCNProcessData

Синтаксис:

Visual Basic:

Function Add(Name As String) As Long

Name - имя обработчика данных

Описание:


Count property (IZCNProcessData)

Возвращает количество обработчиков данных, входящих в расчетную модель сети

Применяется к:

IZCNProcessData

Синтаксис:

Visual Basic:

Property Count() As Long

read only

Описание:


GetNameByIndex method (IZCNProcessData)

Возвращает имя обработчика данных из списка обработчиков по индексу

Применяется к:

IZCNProcessData

Синтаксис:

Visual Basic:

Function GetNameByIndex(Index As Long) As String

Index - индкс в списке обработчиков (нумерация с нуля)

Описание:


GetQuery method (IZCNProcessData)

Возвращает строку с SQL запросом для обработчика с заданным именем

Применяется к:

IZCNProcessData

Синтаксис:

Visual Basic:

Function GetQuery(Name As String) As String

Name - имя обработчика

Описание:


GetRunType method (IZCNProcessData)

Возвращает параметр, определяющий способ применения обработчика с указанным именем

Применяется к:

IZCNProcessData

Синтаксис:

Visual Basic:

Function GetRunType(Name As String) As Long

Name - имя обработчика

Описание:

Возвращаемые значения:

0 - выполняется вручную

1 - выполняется автоматически перед расчетом

2 - выполняется автоматически после расчета


GetTasks method (IZCNProcessData)

Возвращает список номеров задач для которых может выполняется данный обработчик

Применяется к:

IZCNProcessData

Синтаксис:

Visual Basic:

Function GetTasks(Name As String) As IZCNElemIDs

Name - имя обработчика

Описание:

Номера задач:

ZuluThermo:

1 - наладка

2 - поверка

3 - конструкторский

4 - резерв пропускной способности

ZuluHydro:

1 - поверка

2 - конструкторский

4 - резерв пропускной способности

ZuluDrain:

1 - поверка

2 - конструкторский

ZuluGaz:

1 - поверка

2 - конструкторский


Save method (IZCNProcessData)

Сохраняет информацию об обработчиках данных в слой инженерной сети

Применяется к:

IZCNProcessData

Синтаксис:

Visual Basic:

Function Save() As Long

Описание:


SetQuery method (IZCNProcessData)

Задает строку SQL запроса для обработчика с указанным именем

Применяется к:

IZCNProcessData

Синтаксис:

Visual Basic:

Sub SetQuery(Name As String, Query As String)

Name - имя обработчика

Query - строка SQL запроса

Описание:


SetRunType method (IZCNProcessData)

Задает параметр, определяющий способ применения обработчика с указанным именем

Применяется к:

IZCNProcessData

Синтаксис:

Visual Basic:

Sub SetRunType(Name As String, nRunType As Long)

Name - имя обработчика

nRunType - способ вызова обработчика:

0 - выполняется вручную

1 - выполняется автоматически перед расчетом

2 - выполняется автоматически после расчета

Описание:


SetTasks method (IZCNProcessData)

Задает список задач для которых может выполняется данный обработчик

Применяется к:

IZCNProcessData

Синтаксис:

Visual Basic:

Sub SetTasks(Name As String, iTasks As IZCNElemIDs)

Name - имя обработчика

iTasks - объект, содержащий список номеров задач

Описание:

Номера задач:

ZuluThermo:

1 - наладка

2 - поверка

3 - конструкторский

4 - резерв пропускной способности

ZuluHydro:

1 - поверка

2 - конструкторский

4 - резерв пропускной способности

ZuluDrain:

1 - поверка

2 - конструкторский

ZuluGaz:

1 - поверка

2 - конструкторский


ZCNPumpDef Object

Объект IZCNPumpDef описывает насос, используемый в расчетах тепловых и водопроводных сетей. Объект создается при вызове метода ZCNNetwork.AddPumpDef или ZCNNetworkCtrl.AddPumpDef

Свойства и методы:

Свойства

Методы

Hin

Name

PointCount

Speed

AddPoint


AddPoint Method (IZCNPumpDef)

Добавляет новую точку в QH характеристику насоса.

Применяется к:

IZCNPumpDef

Синтаксис:

Visual Basic:

Function AddPoint(Q As Double, H As Double) As Long

Q - расход, м3/ч

H - напор, м

Описание:

В случае успеха возвращает номер точки. При недопустимых значениях Q и H метод вернет -1.


Hin Property (IZCNPumpDef)

Устанавливает\возвращает значение минимального напора на всасе насоса. Напор задается в метрах водяного столба.

Применяется к:

IZCNPumpDef

Синтаксис:

Visual Basic:

Property Hin As Double


Name Property (IZCNPumpDef)

Возвращает строковый идентификатор насоса.

Применяется к:

IZCNPumpDef

Синтаксис:

Property Name As String

read-only


PointCount Property (IZCNPumpDef)

Возвращает количество точек в QH характеристике насоса.

Применяется к:

IZCNPumpDef

Синтаксис:

Property PointCount As Long

read-only


Speed Property (IZCNPumpDef)

Устанавливает\возвращает значение скорости вращения насоса. Скорость вращения задается в оборотах в минуту.

Применяется к:

IZCNPumpDef

Синтаксис:

Visual Basic:

Property Speed As Double


IZCNTGraphRec Object

Объект IZCNTGraphRec представляет запись из таблицы, являющейся результатом расчета температурного графика тепловой сети. Возвращается методом ZCNTaskThermo.TGraphGetRecord (ZCNTaskThermoCtrl.TGraphGetRecord).

Свойства

Свойства

Описание

Gpod

Расход в подающем трубопроводе, т/ч

H

Напор на источнике, м

Tnv

Температура наружного воздуха, °C

Tobr

Температура в обратном трубопроводе, °C

Tpod

Температура в подающем трубопроводе, °C

Tvv

Температура внутреннего воздуха, °C


ZCNNetwork Object

Объект ZCNNetwork представляет модель инженерной сети (тепловой, водопроводной, газовой и т.д.), участвующей в расчетах. Ему соответствует элемент ZCNNetworkCtrl, который можно размещать в качестве визуального компонента на форме в режиме design-time.

В отличие от компонента ZCNNetworkCtrl, объект ZCNNetwork предназначен для создания в режиме run-time как COM-объект. Методы и свойства объекта совпадают с ZCNNetworkCtrl.

Регистрационная информация:

PROGID:

ZuluComNetOcx.ZCNNetwork

CLSID:

{12507502-11DD-4DDC-AFDA-3007DB025F4D}

Свойства:

Методы и свойства объекта совпадают с ZCNNetworkCtrl.

Пример создания:

'Visual Basic:
Dim NetObj As ZuluComNetOcx.ZCNNetwork
Set NetObj = New ZuluComNetOcx.ZCNNetwork
//Delphi:
NetObj: IZCNNetwork;
NetObj := CoZCNNetwork.Create;
'VBScript:
Set NetObj = CreateObject("ZuluComNetOcx.ZCNNetwork")


AboutBox property (ZCNNetwork)

Вызывает панель «О компоненте» с информацией о версии продукта и разработчиках.

Применяется к:

ZCNNetworkCtrl (ZCNNetwork),

ZCNTaskThermoCtrl (ZCNTaskThermo),

ZCNTaskHydroCtrl (ZCNTaskHydro),

ZCNTaskSteamCtrl (ZCNTaskSteam),

ZCNTaskGazCtrl (ZCNTaskGaz),

ZCNOutputCtrl,

ZCNPiezoCtrl

Синтаксис:

Visual Basic:

Sub AboutBox()


AddObject property (ZCNNetwork)

Добавляет объект в модель сети. Модель сети должна быть предварительно создана методом CreateNetwork.

Применяется к:

ZCNNetworkCtrl (ZCNNetwork)

Синтаксис:

Visual Basic:

Function AddObject(Key As Long, Type As Long, Mode As Long, KeyBegin As Long, KeyEnd As Long, Length As Double) As Boolean

Key - ключ (ID) объекта;

Type - тип объекта в модели сети (cv/ N)

Mode - режим объекта

KeyBegin - ID объекта в начале участка (-1 для узлов).

KeyEnd - ID объекта в конце участка (-1 для узлов)

Length - длина участка (0 для узлов).

Описание:

С помощью метода AddObject набирается топология сети. Для каждого элемента сети указывается его ключ (ID), код типа и режим. Для участков сети указываются ID инцидентных узлов в начале (KeyBegin) и конце (KeyEnd) участка, а также его длина. Для узловых элементов параметры KeyBegin и KeyEnd должен быть -1, а Length - 0.


AddPumpDef Method (ZCNNetwork)

Добавляет в модель сети объект для описания нового насоса.

Применяется к:

ZCNNetworkCtrl (ZCNNetwork)

Синтаксис:

Visual Basic:

Function AddPumpDef(Name As String) As IZCNPumpDef

Name - строковый идентификатор насоса

Описание:

Используя возвращаемый методом объект IZCNPumpDef можно задать QH характеристику и другие параметры насоса.

Пример:

Dim NW As ZCNNetwork
'Создаем сеть
Set NW = New ZCNNetwork

Dim pump As IZCNPumpDef
'Добавляем в сеть описатель насоса
Set pump = NW.AddPumpDef("Насос-1")
'Задаем точки QH характеристики
pump.AddPoint 6, 21
pump.AddPoint 10, 19
pump.AddPoint 16, 13
'Добавляем в сеть объект "Насос"
NW.AddObject 5, 4, 1, -1, -1, 0
'Задаем для этого объекта марку насоса на подающем (тепловая сеть)
NW.SetAttrValue 5, "Mark_pod", "Насос-1"


Clear method (ZCNNetwork)

Удаляет все объекты сети, созданной с помощью метода CreateNetwork, оставляя структуру сети без изменений. После выполнения метода Clear сеть может быть заполнена заново.

Применяется к:

ZCNNetworkCtrl (ZCNNetwork)

Синтаксис:

Visual Basic:

Sub Clear()


CreateNetwork method (ZCNNetwork)

Создает новую сеть с указанной структурой в зависимости от типа сети.

Применяется к:

ZCNNetworkCtrl (ZCNNetwork)

Синтаксис:

Visual Basic:

Function CreateNetwork(Type As Long) As Boolean

Type - тип сети из набора констант zcnNetworkType.

Значения zcnNetTypeAuto, zcnNetTypeUndef недопустимы.


GetAttrValue method (ZCNNetwork)

Возвращает значение атрибута элемента сети.

Применяется к:

ZCNNetworkCtrl (ZCNNetwork)

Синтаксис:

Visual Basic:

Function GetAttrValue(Key As Long, Attr)

Delphi:

function GetAttrValue(Key: Integer; Attr: OleVariant): OleVariant;

Key - ID элемента, чей атрибут читается.

Attr - имя или код атрибута

Описание:

Значение Attr задается либо в виде строки, где указывается имя атрибута, либо в виде кода атрибута, которым является порядковый номер этого атрибута, начиная с 1.

В случае числового атрибута метод возвращает вещественное значение, иначе в случае строкового атрибута метод вернет строку.

Пример:

X = NetCtrl1.GetAttrValue(ElemID, "Dpod")


GetProcessData method (ZCNNetwork)

Возвращает объект IZCNProcessData с информацией о списке команд по обработке данных при выполнении гидравлических расчетов

Применяется к:

ZCNNetworkCtrl (ZCNNetwork)

Синтаксис:

Visual Basic:

Function GetProcessData() As IZCNProcessData

Описание:


NetType property (ZCNNetwork)

Определяет тип инженерной сети (тепловая, водопроводная и т.д.). Возможные значения определяются константами zcnNetworkType.

Применяется к:

ZCNNetworkCtrl (ZCNNetwork)

Синтаксис:

Visual Basic:

Property NetType As Long


OpenNetwork method (ZCNNetwork)

Загружает сеть из слоя Zulu.

Применяется к:

ZCNNetworkCtrl (ZCNNetwork)

Синтаксис:

Visual Basic:

Function OpenNetwork(Path As String, Type As Long) As Boolean

Path - путь к слою Zulu (файл .b00)

Type - тип сети (см. zcnNetworkType)


SetAttrValue method (ZCNNetwork)

Задает значение атрибута элемента сети.

Применяется к:

ZCNNetworkCtrl (ZCNNetwork)

Синтаксис:

Visual Basic:

Function SetAttrValue(Key As Long, Attr, Value) As Boolean

Delphi:

function SetAttrValue(Key: Integer; Attr: OleVariant; Value: OleVariant): WordBool;

Key - ID элемента, чей атрибут записывается.

Attr - имя или код атрибута

Value - значение атрибута

Описание:

После того, как элемент добавлен в модель сети с помощью метода AddObject, последовательностью вызовов метода SetAttrValue задаются параметры этого элемента (такие как: длина и диаметр трубопровода, геодезическая отметка узлов, расчетный располагаемый напор на выходе из источника и т.п.)

Значение Attr задается либо в виде строки, где указывается имя атрибута, либо в виде кода атрибута, которым является порядковый номер этого атрибута, начиная с 1.


ZCNTaskDrain Object

Объект ZCNTaskDrain представляет расчеты ZuluDrain. Ему соответствует элемент ZCNTaskDrainCtrl, который можно размещать в качестве визуального компонента на форме в режиме design-time.

В отличие от компонента ZCNTaskDrainCtrl, объект ZCNTaskDrain предназначен для создания в режиме run-time как COM-объект. Методы и свойства объекта совпадают с ZCNTaskDrainCtrl.

Пример создания объекта:

'Visual Basic:
Dim task As ZCNTaskDrain
Set task = New ZCNTaskDrain
//Delphi:
task: IZCNTaskDrain;
task := CoZCNTaskDrain.Create;


ZCNTaskGaz Object

Объект ZCNTaskGaz представляет расчеты ZuluGaz. Ему соответствует элемент ZCNTaskGazCtrl, который можно размещать в качестве визуального компонента на форме в режиме design-time.

В отличие от компонента ZCNTaskGazCtrl, объект ZCNTaskGaz предназначен для создания в режиме run-time как COM-объект. Методы и свойства объекта совпадают с ZCNTaskGazCtrl.

Пример создания объекта:

'Visual Basic:
Dim task As ZCNTaskGaz
Set task = New ZCNTaskGaz
//Delphi:
task: IZCNTaskGaz;
task := CoZCNTaskGaz.Create;


ZCNTaskHydro Object

Объект ZCNTaskHydro представляет расчеты ZuluHydro. Ему соответствует элемент ZCNTaskHydroCtrl, который можно размещать в качестве визуального компонента на форме в режиме design-time.

В отличие от компонента ZCNTaskHydroCtrl, объект ZCNTaskHydro предназначен для создания в режиме run-time как COM-объект. Методы и свойства объекта совпадают с ZCNTaskHydroCtrl.

Пример создания объекта:

'Visual Basic:
Dim task As ZCNTaskHydro
Set task = New ZCNTaskHydro
//Delphi:
task: IZCNTaskHydro;
task := CoZCNTaskHydro.Create;


ZCNTaskSteam Object

Объект ZCNTaskSteam представляет расчеты ZuluSteam. Ему соответствует элемент ZCNTaskSteamCtrl, который можно размещать в качестве визуального компонента на форме в режиме design-time.

В отличие от компонента ZCNTaskSteamCtrl, объект ZCNTaskSteam предназначен для создания в режиме run-time как COM-объект. Методы и свойства объекта совпадают с ZCNTaskSteamCtrl.

Пример создания объекта:

'Visual Basic:
Dim task As ZCNTaskSteam
Set task = New ZCNTaskSteam
//Delphi:
task: IZCNTaskSteam;
task := CoZCNTaskSteam.Create;


ZCNNetwork Object

Объект ZCNTaskThermo представляет расчеты ZuluThermo. Ему соответствует элемент ZCNTaskThermoCtrl, который можно размещать в качестве визуального компонента на форме в режиме design-time.

В отличие от компонента ZCNTaskThermoCtrl, объект ZCNTaskThermo предназначен для создания в режиме run-time как COM-объект. Методы и свойства объекта совпадают с ZCNTaskThermoCtrl.

Пример создания объекта:

'Visual Basic:
Dim task As ZCNTaskThermo
Set task = New ZCNTaskThermo
//Delphi:
task: IZCNTaskThermo;
task := CoZCNTaskThermo.Create;


CalcStatus property

Возвращает состояние текущей расчетной задачи.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo),

ZCNTaskHydroCtrl (ZCNTaskHydro),

ZCNTaskSteamCtrl (ZCNTaskSteam),

ZCNTaskGazCtrl (ZCNTaskGaz)

Синтаксис:

Visual Basic:

Property CalcStatus As Long

read-only

Описание:

Свойство возвращает состояние текущей расчетной задачи. Может принимать значение из набора констант zcnCalcStatus.


Cancel method

Прерывает выполнение текущей расчетной задачи.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo),

ZCNTaskHydroCtrl (ZCNTaskHydro),

ZCNTaskSteamCtrl (ZCNTaskSteam),

ZCNTaskGazCtrl (ZCNTaskGaz)

Синтаксис:

Visual Basic:

Sub Cancel(bWait As Boolean)

Описание:

Метод прерывает выполнение текущей запущенной расчетной задачи. Если в настоящий момент нет запущенной задачи или задача уже закончила выполнение, метод ничего не делает.

Если параметр bWait равен True, метод ждет завершения прерываемой задачи и только после этого передает управление вызываемой программе, иначе, если False, метод только предписывает задаче завершиться (свойство CalcStatus равно 1) и сразу возвращает управление, задача завершит работу через небольшой промежуток времени.

После того, как задача оказывается прерванной свойство CalcStatus принимает значение zcnCalcStop и возникает событие OnCalcFinish с параметром bCancel равным True.


ConstructGetCriterium method

Возвращает условия (критерии) для проведения конструкторского расчета.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function ConstructGetCriterium() As Long


ConstructGetMinD method

Возвращает значение минимального диаметра Hmin в метрах, используемое для проведения конструкторского расчета.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function ConstructGetMinD() As Double


ConstructGetStartID method

Возвращает ID участка подключения — элемента сети, начиная с которого будет определяться подсеть для проведения конструкторского расчета.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function ConstructGetStartID() As Long


ConstructSetCriterium method

Устанавливает условия (критерии) для проведения конструкторского расчета и подбора диаметров трубопроводов.

Применяется к:

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function ConstructSetCriterium(NewVal As Long) As Long

Где

NewVal -

Возможные параметры

0 по скоростя

1 по уд пот

2 по миним напорам


ConstructSetMinD method

Устанавливает значение минимального диаметра Hmin в метрах, используемое для проведения конструкторского расчета.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function ConstructSetMinD(NewVal As Double) As Double

Где:

NewVal — значение минимального внутреннего диаметра, в метрах.


ConstructSetStartID method

Устанавливает ID участка подключения — элемента сети, начиная с которого будет определяться подсеть для проведения конструкторского расчета.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskThermoCtrl (ZCNTaskHydro)

Синтаксис:

Function ConstructSetStartID(NewVal As Long) As Long

Где:

NewVal — ID элемента сети.


Errors property

Возвращает список ошибок и сообщений, возникших в ходе выполнения расчета, в виде коллекции IZCNErrors.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo, Коды ошибок ZuluThermo),

ZCNTaskHydroCtrl (ZCNTaskHydro ZCNNetwork Object, Коды ошибок ZuluHydro),

ZCNTaskSteamCtrl (ZCNTaskSteam ZCNNetwork Object, Коды ошибок ZuluSteam),

ZCNTaskGazCtrl (ZCNTaskGaz ZCNNetwork Object, Коды ошибок ZuluGaz)

ZCNTaskDrainCtrl (ZCNTaskDrain ZCNTaskDrain Object, Коды ошибок ZuluDrain)

Синтаксис:

Visual Basic:

Property Errors As IZCNErrors

read-only


GetStepNodeValue method

Возвращает значение

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function GetStepNodeValue() As Long


GetStepPipeValue method

Возвращает значение

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function GetStepPipeValue() As Long


LogMessages property

Выводить не выводить все сообщения протокола расчета.

Синтаксис:

Visual Basic:

Property LogMessages As Long

read-only ?


MaxGot property

Возвращает\устанавливает максимальное значение относительного расхода, до которого может быть увеличен расход на потребителе при наладочном расчете.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property MaxGot As Double


MaxGot property

Возвращает\устанавливает значение минимального диаметра шайбы в миллиметрах.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property MinDShb As Double


MinDSoplo property

Возвращает\устанавливает значение минимального диаметра сопла элеватора в миллиметрах.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property MinDSoplo As Double


NaladkaThermoLoss property

Возвращает/устанавливает способ учета тепловых потерь при выполнении наладочного расчета.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property NaladkaThermoLoss As Long

Описание:

Свойство может принимать следующие значения:

0 - расчет без учета тепловых потерь

1 - расчет с нормативными тепловыми потерями

2 - расчет тепловых потерь по параметрам изоляции


NaladkaUseGVS property

Возвращает\устанавливает признак учета открытого водоразбора из систем горячего водоснабжения при наладочном расчете.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property NaladkaUseGVS As Boolean


NaladkaUseLeaks property

Возвращает\устанавливает признак учета утечек из трубопроводов и систем теплопотребления в наладочном расчете.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property NaladkaUseLeaks As Boolean


NaladkaUseSoplo property

Возвращает\устанавливает признак гашения избыточного напора соплом элеватора (для элеваторных схем) в наладочном расчете.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property NaladkaUseSoplo As Boolean


Network property

Возвращает/устанавливает инженерную сеть, расчеты которой будут проводиться.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo),

ZCNTaskHydroCtrl (ZCNTaskHydro),

ZCNTaskSteamCtrl (ZCNTaskSteam),

ZCNTaskGazCtrl (ZCNTaskGaz),

ZCNPiezoCtrl

Синтаксис:

Visual Basic:

Property Network As ZCNNetwork

Описание:

Свойство Network можно задать в режиме run-time, либо использовать свойство NetworkCtrlName для подключения элемента ZCNNetworkCtrl в design-time или run-time.

Примеры:

Пример1 (VisualBasic):
'подключается объект ZCNNetwork
Dim NetObj As ZCNNetwork
Set NetObj = New ZCNNetwork
Set ZCNTaskThermoCtrl1.Network = NetObj

Пример2 (VisualBasic):
'подключается элемент ZCNNetworkСtrl
Set ZCNTaskThermoCtrl1.Network = ZCNNetworkСtrl1.Object


NetworkCtrlName property

Возвращает/устанавливает имя элемента ZCNNetworkCtrl, с которым связан данный элемент. Служит для связывания между собой элементов, расположенных на одной форме, в режиме design-time.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo),

ZCNTaskHydroCtrl (ZCNTaskHydro),

ZCNTaskSteamCtrl (ZCNTaskSteam),

ZCNTaskGazCtrl (ZCNTaskGaz),

ZCNPiezoCtrl

Синтаксис:

Visual Basic:

Property NetworkCtrlName As String

Описание:

Свойство NetworkCtrlName служит для связывания с элементом ZCNNetworkCtrl в режиме design-time. Для того, чтобы подключить объект "сеть" к данному элементу в режиме run-time можно воспользоваться свойством Network.


Cancel method

Возникает при завершении выполнения расчетной задачи.

Применяется к:

ZCNTaskThermoCtrl,

ZCNTaskHydroCtrl,

ZCNTaskSteamCtrl,

ZCNTaskGazCtrl

Синтаксис:

Visual Basic:

Event OnCalcFinish(bCanceled As Boolean)

Описание:

Событие возникает при завершении выполнения расчетной задачи. Параметр bCanceled указывает на то, была ли задача прервана (True) или завершила работу штатно (False).


OutputCtrlName property

Возвращает/устанавливает имя элемента ZCNOutputCtrl, с которым связан данный элемент. Служит для связывания между собой элементов, расположенных на одной форме, в режиме design-time. Протокол расчета будет размещаться в указанном элементе Output.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo),

ZCNTaskHydroCtrl (ZCNTaskHydro),

ZCNTaskSteamCtrl (ZCNTaskSteam),

ZCNTaskGazCtrl (ZCNTaskGaz)

Синтаксис:

Visual Basic:

Property OutputCtrlName As String

Описание:

Свойство OutputCtrlName служит для связывания с элементом ZCNOutputCtrl в режиме design-time для того, чтобы протокол расчеты шел в окно этого элемента.

Для задания окна вывода протокола в режиме run-time можно воспользоваться методом SetOutput.


PoverkaCalcRo property

Возвращает\устанавливает признак определения плотности по фактической температуре трубопроводов в поверочном расчете.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property PoverkaCalcRo As Boolean


PoverkaNotFixed property

Устанавливает признак проведения поверочного расчета: с фиксированным или не фиксированным отбором воды.

Применяется к:

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Visual Basic:

Property PoverkaNotFixed As Boolean

Возможные значения:

false - с нефиксированным отбором воды.

true - с фиксированным набором воды.


PoverkaSummerMode property

Возвращает/устанавливает значение опции Летний режим для поверочного расчета.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property PoverkaSummerMode As Boolean


PoverkaThermoLoss property

Возвращает/устанавливает способ учета тепловых потерь при выполнении поверочного расчета.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property PoverkaThermoLoss As Long

Описание:

Свойство может принимать следующие значения:

0 - расчет без учета тепловых потерь

1 - расчет с нормативными тепловыми потерями

2 - расчет тепловых потерь по параметрам изоляции


PoverkaUseFromNaladka property

Возвращает/устанавливает способ получения значений диаметров шайб и сопел элеваторов для поверочного расчета.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property PoverkaUseFromNaladka As Boolean


PoverkaUseLeaks property

Возвращает/устанавливает признак учета утечек из трубопроводов и систем теплопотребления в поверочном расчете.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property PoverkaUseLeaks As Boolean


ReserveAddColorInterval method

Устанавливает параметры тематической раскраски по результатам расчета резерва сети: диапазон значений и цвет.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function ReserveAddColorInterval(G1 As Double, G2 As Double, rgbColor As Long) As Long

Где:

G1 — начальное значение диапазона раскраски (м3/ч или т/ч).

G2 — конечное значение диапазона раскраски (м3/ч или т/ч).

rgbColor — значение цвета в формате rgb.


ReserveRunStep method

Возвращает значение

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function ReserveRunStep(Flags As Long) As Long


ReserveSetHmin method

Устанавливает значение минимального напора Hmin для проведения расчета резерва сети.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function ReserveSetHmin(H As Double) As Long

Где:

H — значение минимального напора Hmin для проведения расчета резерва сети.


ReserveSetOutputLayer method

Возвращает значение

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function ReserveSetOutputLayer(Name As String, UserName As String) As Long


ReserveSetStep method

Для расчета резерва сети, устанавливает шаг, с которым будет осуществляться подключение новых нагрузок.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function ReserveSetStep(dStep As Double) As Long

Где:

dStep — шаг в метрах.


ReserveStartStepCalc method

Устанавливает шаг

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function ReserveStartStepCalc(Flags As Long) As Long


ReserveStopStepCalc method

Устанавливает шаг

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function ReserveStopStepCalc() As Long


RoObr property

Возвращает\устанавливает значение плотности теплоносителя в обратном трубопроводе в т/м3.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property RoObr As Double


RoPod property

Возвращает\устанавливает значение плотности теплоносителя в подающем трубопроводе в т/м3.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property RoPod As Double


Run method

Запускает расчетную задачу.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo),

ZCNTaskHydroCtrl (ZCNTaskHydro),

ZCNTaskSteamCtrl (ZCNTaskSteam),

ZCNTaskGazCtrl (ZCNTaskGaz)

Синтаксис:

Visual Basic:

Function Run(nTask As Integer, bWait As Boolean) As Boolean

nTask - код задачи из набора констант zcnTaskCode;

bWait - флаг ожидания завершения расчета.

Описание:

Метод запускает расчетную задачу, указанную в параметре nTask. В случае, если задача успешно запущена, метод вернет True, иначе False. При этом, если флаг bWait равен True, то метод не закончит работу (не вернет значение) до завершения процедуры расчета. Если bWait указан False, то метод запустит задачу и, если задача запущена успешно, вернет True, иначе - False.

В один и тот же момент времени компонент может выполнять только одну расчетную задачу. Повторный вызов метода Run в момент выполнения задачи вернет False.

Если флаг bWait имеет значение False, то метод сразу возвращает результат, в зависимости от того, удалось ли запустить задачу. Расчетная задача запускается в отдельном потоке. Выяснить, когда задача закончит выполнение можно периодически (например по таймеру) контролировать свойство CalcStatus, либо обрабатывать событие OnCalcFinish.


RunStep method

Запускает расчетную задачу пошагово ?.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo),

ZCNTaskHydroCtrl (ZCNTaskHydro),

ZCNTaskSteamCtrl (ZCNTaskSteam),

ZCNTaskGazCtrl (ZCNTaskGaz)

Синтаксис:

Visual Basic:

Function RunStep(, bWait As Boolean

Описание:

Метод запускает расчетну\

Пример кода на vbscript

' ActiveX enumeration values definitions start (do not change!)
Const zcnNetTypeHydro = 2
' ActiveX enumeration values definitions end

Sub RunOnline

Set Out = Zulu.OpenOutputChannel("Сообщения")

Set nw  = CreateObject("ZuluComNetOcx.Network")
Set task = CreateObject("ZuluComNetOcx.TaskThermo")

Out.Clear

nw.OpenNetwork "D:\Lyosha\Orenburg\Оренбург_2026.b00", zcnNetTypeThermo

task.Network = nw

task.ReserveSetOutputLayer "D:\Test\ReserveOcx.b00", "ReserveOcx"

task.SetOutput Out

task.SetSource 144595, True
task.CalibrSetFlags 1

task.Run 5, True

End Sub

Sub ChangeKe

Set Out = Zulu.OpenOutputChannel("Сообщения")

Set nw  = CreateObject("ZuluComNetOcx.Network")
Set task = CreateObject("ZuluComNetOcx.TaskHydro")

Out.Clear

nw.OpenNetwork "D:\Zulu 8.0\Examples\Hydro\Sample1\water supply.b00", zcnNetTypeHydro

task.Network = nw

'task.SetOutput Out

If task.StartStepCalc (0) = 0 Then

Ke = 0.1

For j = 1 To 25

task.SetStepPipeValue 149, "Ke", Ke

Ke = Ke + 1

task.RunStep 0

S = "Ke=" + CStr(Ke) + " P=" + CStr(task.GetStepNodeValue(198, "P")) + CHR(10)

S = Replace (S, ",", ".")

Out.Put S

Next

task.StopStepCalc

End If

End Sub

Sub ChangeG

Set Out = Zulu.OpenOutputChannel("Сообщения")

Set nw  = CreateObject("ZuluComNetOcx.Network")
Set task = CreateObject("ZuluComNetOcx.TaskHydro")

Out.Clear

nw.OpenNetwork "D:\Hydro\Sample1\water supply.b00", zcnNetTypeHydro

task.Network = nw

'task.SetOutput Out

If task.StartStepCalc (0) = 0 Then

G = 0.1

For j = 1 To 25

task.SetStepNodeValue 198, "G", G

G = G + 1

task.RunStep 0

S = "G=" + CStr(task.GetStepPipeValue(149, "G")) + " G199=" + CStr(task.GetStepPipeValue(199, "G")) + " P=" + CStr(task.GetStepNodeValue(198, "P")) + CHR(10)

S = Replace (S, ",", ".")

Out.Put S

Next

task.StopStepCalc

Out.Put "Finish" + CHR(10)

End If

End Sub


RunTaskMode property

Возвращает/устанавливает режим выполнения гидравлического расчета.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property RunTaskMode As Long

Описание:

Возможные значения свойства:

0 - обычный режим расчета

1 - режим проверки исходных данных без проведения расчета


SetMinPipeLength method

Устанавливает значение длины участка L, сопротивлением которых расчет пренебрегает (сопротивление этих стремится к нулю).

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function SetMinPipeLength(L As Double) As Long

Где:

L — значение длины участка L в метрах.


SetOutput method

Устанавливает окно вывода протокола расчета.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo),

ZCNTaskDrainCtrl (ZCNTaskDrain),

ZCNTaskHydroCtrl (ZCNTaskHydro),

ZCNTaskSteamCtrl (ZCNTaskSteam),

ZCNTaskGazCtrl (ZCNTaskGaz)

Синтаксис:

Visual Basic:

Sub SetOutput(Output)

Описание:

Метод SetOutput используется для задания окна вывода протокола расчета в режиме run-time. В качестве параметра Output можно указывать элемент ZCNOutputCtrl. В режиме design-time окно ZCNOutputCtrl можно подключить с помощью свойства OutputCtrlName.

Пример (VisualBasic):
ZCNTaskThermo1.SetOutput(ZCNOutputCtrl1.Object)


SetSource property

Задает список источников, участвующих в расчетах, в виде коллекции идентификаторов элементов IZCNElemIDs.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo),

ZCNTaskHydroCtrl (ZCNTaskHydro),

ZCNTaskSteamCtrl (ZCNTaskSteam),

ZCNTaskGazCtrl (ZCNTaskGaz)

Синтаксис:

Visual Basic:

Property SetSource(nSourceID As Long, bUse As Boolean) As Long

Описание:

Свойство SetSource возвращает к


SetStepNodeValue method

Устанавливает шаг

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function SetStepNodeValue(Key As Long, Attr As String, Value As Double) As Long


SetStepPipeValue method

Устанавливает шаг

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

ZCNTaskHydroCtrl (ZCNTaskHydro)

Синтаксис:

Function SetStepPipeValue(Key As Long, Attr As String, Value As Double) As Long


Sources property

Возвращает список источников, участвующих в расчетах, в виде коллекции идентификаторов элементов IZCNElemIDs.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo),

ZCNTaskHydroCtrl (ZCNTaskHydro),

ZCNTaskSteamCtrl (ZCNTaskSteam),

ZCNTaskGazCtrl (ZCNTaskGaz)

Синтаксис:

Visual Basic:

Property Sources As IZCNElemIDs

Описание:

Свойство Sources возвращает коллекцию IZCNElemIDs идентификаторов узлов-источников, с помощью которой задается какие подсети будут рассчитываться. Для расчетов необходимо, чтобы коллекция содержала по крайней мере один элемент.


StartStepCalc method

Запускает

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Function StartStepCalc(Flags As Long) As Long


StopStepCalc method

Запускает

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Function StopStepCalc(Flags As Long) As Long


TGraphGetPotrebID method

Возвращает ID элемента сети (потребителя) на который будет проводиться расчет температурного графика сети.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Function TGraphGetPotrebID() As Long


TGraphGetRecordCount method

Возвращает запись из таблицы ответа по расчету температурного графика тепловой сети в виде объекта IZCNTGraphRec.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Function TGraphGetRecord(Index As Long) As IZCNTGraphRec

Index - порядковый номер записи в таблице ответа


TGraphGetRecordCount method

Возвращает количество записей в таблице, являющейся результатом расчета температурного графика сети.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Function TGraphGetRecordCount() As Long


TGraphNaporFlag property

Возвращает\устанавливает признак регулирования напором на источнике при расчете температурного графика.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property TGraphNaporFlag As Boolean


TGraphSetPotrebID method

Устанавливает ID элемента сети (потребителя) на который будет проводиться расчет температурного графика сети.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Function TGraphSetPotrebID(NewVal As Long) As Long

NewVal - ID потребителя

Описание:

Если заданное значение ID действительно соответствует потребителю, связанному с одним из источников сети, метод вернет значение ID источника. В случае неуспеха, метод возвращает отрицательное значение.


TGraphTPolka property

Возвращает\устанавливает значение температуры полки (наименьшей температуры на источнике) при расчете температурного графика.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property TGraphTPolka As Double


TGraphTSrezka property

Возвращает\устанавливает значение температуры срезки (наибольшей температуры на источнике) при расчете температурного графика.

Применяется к:

ZCNTaskThermoCtrl (ZCNTaskThermo)

Синтаксис:

Property TGraphTSrezka As Double


Константы

  • zcnCalcStatus enum

    Константы, определяющие состояние выполняемой задачи. См. свойство CalcStatus.

  • zcnNetworkType enum

    Константы, определяющие тип инженерной сети (тепловая, водопроводная, газовая и т.д.).

  • zcnTaskCode enum

    Константы, определяющие код выполняемого расчета. См. метод Run.

  • zcnTaskType enum

    Константы, определяющие тип расчетов, панель которых внедряется в окно элемента ZCNTaskWinCtrl.


zcnCalcStatus enum

Константы, определяющие состояние выполняемой задачи. См. свойство CalcStatus.

Константа

Описание

zcbCalcReady = 0

Нет запущенной задачи, либо последняя запущенная задача успешно выполнена.

zcbCalcBusy = 1

Одна из расчетных задач запущена и в настоящий момент выполняется.

zcbCalcStop = 2

Текущая расчетная задача находится в процессе завершения работы.


zcnNetworkType enum

Константы, определяющие тип инженерной сети (тепловая, водопроводная, газовая и т.д.).

См. свойство NetType объекта ZCNNetworkCtrl и ZCNNetwork.

Константа

Описание

zcnNetTypeAuto = 0

Тип не определен и определяется автоматически (см. метод OpenNetwork).

zcnNetTypeUndef = 0

Тип cети не определен (начальное значение до того как сети будет создана или загружена).

zcnNetTypeThermo = 1

Тепловая сеть

zcnNetTypeHydro = 2

Водопроводная сеть

zcnNetTypeSteam = 3

Паровая сеть

zcnNetTypeGas = 4

Газовая сеть

zcnNetTypeDrain = 5

Канализационная сеть


zcnTaskCode enum

Константы, определяющие код выполняемого расчета. См. метод Run.

Константа

Описание

zcnTaskThermoNaladka = 1

Наладочный расчет тепловой сети

zcnTaskThermoPoverka = 2

Поверочный расчет тепловой сети

zcnTaskThermoConstruct = 4

Конструкторский расчет тепловой сети

zcnTaskHydroPoverka = 1

Поверочный расчет водопроводной сети

zcnTaskHydroConstruct = 2

Конструкторский расчет водопроводной сети


zcnTaskType enum

Константы, определяющие тип расчетов, панель которых внедряется в окно элемента ZCNTaskWinCtrl.

Описание

Константа

Описание

zcnZuluThermo = 1

панель ZuluThermo

zcnZuluHydro = 2

панель ZuluHydro

zcnZuluSteam = 3

панель ZuluSteam

zcnZuluGaz = 4

панель ZuluGaz

zcnZuluDrain = 5

панель ZuluDrain


Коды ошибок

  • Коды сообщений ZuluDrain

  • Коды сообщений ZuluGaz

  • Коды сообщений ZuluHydro

  • Коды сообщений ZuluSteam

  • Коды сообщений ZuluThermo


Коды сообщений ZuluDrain

Коды ошибок и предупреждений после выполнения расчета можно прочитать из коллекции Errors.

Описание:

Сообщения с кодом меньшим 600 являются ошибками. При наличии ошибок расчет останавливается. Остальные сообщения являются предупреждениями.

Поля таблицы соответствуют свойствам объекта IZCNError. Крестики в ячейках таблицы указывают на то, какие поля являются значимыми для соответствующего сообщения.

Список кодов:

Code

Описание

Key

Name

Type

Param1

Param2

1

Неверное значение поля

X

X

2

Узел имеет неверное количество связей

X

3

В конструкторском расчете из узла может выходить только один участок

X

4

Отсутствуют данные по объекту

X

5

Не открылась база для объектов

X

6

Не выполнен запрос к базе по объектам

X

7

В базе по объекту не задано поле исходных данных для значения

X

8

Не записан ответ

9

В базе объектов не найдено поле

X

10

Отметка дна колодца больше отметки поверхности земли

X

X

X

11

Пустой сортамент

X

12

В сортаменте отсутствует минимально необходимый диаметр

X

X

13

Узел содержит недопустимый набор связей

X

14

Из узла один участок должен выходить

X

15

Неверное значение диаметра в сортаменте

X

X

16

Неверное значение минимальной скорости в сортаменте

X

X

17

Неверное значение заполнения в сортаменте

X

X

18

Неверное значение шероховатости в сортаменте

X

X

200 | Сообщение | X
601 | Участок не имеет узла | X
602 | Полное заполнение при наибольшем диаметре для данного сортамента | X
603 | Излив на землю | X | X
604 | Погрешность суммы расходов в узле | X | X
801 | Не записать результат в базу : не найдено поле | X | X


Коды сообщений ZuluGaz

Коды ошибок и предупреждений после выполнения расчета можно прочитать из коллекции Errors.

Описание:

Сообщения с кодом меньшим 600 являются ошибками. При наличии ошибок расчет останавливается. Остальные сообщения являются предупреждениями.

Поля таблицы соответствуют свойствам объекта IZCNError. Крестики в ячейках таблицы указывают на то, какие поля являются значимыми для соответствующего сообщения.

Список кодов:

Code

Описание

Key

Name

Type

Param1

1

Неверное значение поля

X

X

2

Узел имеет неверное количество связей

X

3

Нулевой участок

X

4

Неправильно задан состав газовой смеси

5

Отсутствуют данные по объекту

X

6

Регулятор в кольце

X

7

В сети нет источников

8

В сети отсутствуют потребители

9

Не открылась база для объектов

X

X

10

Не выполнен запрос к базе по объектам

X

X

11

В данный узел один участок должен входить, другой - выходить

X

12

В базе не задано поле исходных данных для значения

X

X

13

Давление в узле меньше атмосферного

X

14

Не записан ответ

15

Температура в узле меньше -100 градусов

X

16

Несвязный граф

17

В базе объектов не найдено поле

X

X

18

Не выбран ни один источник для расчета

200

Отсутствует лицензия на использование ZuluNetTools совместно с ZuluGaz

601

Участок не имеет узла

X

602

Давление на потребителе ниже минимального

X

X

603

Давление на потребителе превышает максимальное

X

X

604

Давление на входе регулятора ниже давления на выходе

X

X

605

У пара на входе потребителя не хватает давления

X

X

801

Не записать результат в базу: не найдено поле

X

X


Коды сообщений ZuluHydro

Коды ошибок и предупреждений после выполнения расчета можно прочитать из коллекции Errors.

Описание:

Сообщения с кодом меньшим 600 являются ошибками. При наличии ошибок расчет останавливается. Остальные сообщения являются предупреждениями.

Поля таблицы соответствуют свойствам объекта IZCNError Крестики в ячейках таблицы указывают на то, какие поля являются значимыми для соответствующего сообщения.

Список кодов:

Code

Описание

Key

Name

Type

Param1

1

Неверное значение поля

X

X

2

Узел имеет неверное количество связей

X

3

Нулевой участок

X

4

Нет данных по объектам

X

5

Отсутствуют данные по объекту

X

6

Для насоса, заданного как источник возмущения, неверно задан КПД

X

7

Не выполнен запрос к базе по объектам

X

X

8

Насос, заданный как источник возмущения, не описан характеристикой

X

9

Не открылась база для объектов

X

X

10

Регулятор имеет неверное количество связей

X

11

В данный узел один участок должен входить, другой - выходить

X

12

Регулятор может быть связан только с одним вспомогательным участком

X

13

Запорное устройство, заданное как источник возмущения, не описано характеристикой

X

14

Не записан ответ

15

Регулятор может быть соединен вспомогательным участком только с простым узлом

X

16

В источник может входить только один участок

X

17

Из источника должен выходить хотя бы один участок

X

18

Неверный режим потребителя

X

19

В сети все источники отключены

20

В базе не найдено поле

X

X

21

Между регулятором и узлом наблюдения имеются ответвления

X

22

Не выбран ни один источник для расчета

200

Отсутствует лицензия на использование ZuluNetTools совместно с ZuluHydro

601

Участок не имеет узла

X

602

Давление на всасе насоса ниже допустимого

X

603

Потребитель не получает воду

X

604

Недостаточно напора на потребителе

X

X

607

Предупреждение расчета потокораспределения

X

X

801

Не записать результат в базу : не найдено поле

X

X


Коды сообщений ZuluSteam

Коды ошибок и предупреждений после выполнения расчета можно прочитать из коллекции Errors.

Описание:

Сообщения с кодом меньшим 600 являются ошибками. При наличии ошибок расчет останавливается. Остальные сообщения являются предупреждениями.

Поля таблицы соответствуют свойствам объекта IZCNError. Крестики в ячейках таблицы указывают на то, какие поля являются значимыми для соответствующего сообщения.

Список кодов:

Code

Описание

Key

Name

Type

Param1

1

Неверное значение поля

X

X

2

Узел имеет неверное количество связей

X

3

Нулевой участок

X

4

Нет данных по объектам

X

5

Отсутствуют данные по объекту

X

6

Не записан ответ

7

Не выполнен запрос к базе по объектам

X

X

8

Неверный режим потребителя

X

9

Не открылась база для объектов

X

X

10

В сети все источники отключены

11

В данный узел один участок должен входить, другой - выходить

X

12

В сети отсутствуют потребители

13

В первичном контуре теплообменника отрицательный расход

X

14

У сопла Вентури отрицательный расход

X

15

У сепаратора отрицательный расход

X

16

Задавило РОУ

X

17

Давление в узле меньше атмосферного

X

18

Температура в узле меньше 1 градуса

X

19

Задавило турбину

X

20

В базе не найдено поле

X

X

21

Несвязный граф

22

Ошибка исходных данных

X

23

Не выбран ни один источник для расчета

200

Отсутствует лицензия на использование ZuluNetTools совместно с ZuluSteam

601

Участок не имеет узла

X

602

На источнике превышена производительность

X

X

603

На турбине превышена производительность

X

X

604

Наладка не произведена. У пара на входе потребителя не хватает давления

X

X

605

У пара на входе потребителя не хватает давления

X

X

606

Наладка не произведена. У пара на входе потребителя не хватает температуры

X

X

607

У пара на входе потребителя не хватает температуры

X

X

608

Наладка не произведена. У пара на входе потребителя избыток влажности

X

X

609

У пара на входе потребителя избыток влажности

X

X

801

Не записать результат в базу: не найдено поле

X

X


Коды сообщений ZuluThermo

Коды ошибок и предупреждений после выполнения расчета можно прочитать из коллекции Errors.

Описание:

Сообщения с кодом меньшим 600 являются ошибками. При наличии ошибок расчет останавливается. Остальные сообщения являются предупреждениями.

Поля таблицы соответствуют свойствам объекта IZCNError. Крестики в ячейках таблицы указывают на то, какие поля являются значимыми для соответствующего сообщения.

Список кодов:

Code

Описание

Key

Name

Type

Param1

Param2

1

Неверное значение поля

X

X

2

Узел имеет неверное количество связей

X

3

Нулевой участок

X

4

Нет данных по объектам

X

5

Отсутствуют данные по объекту

X

6

Не задан участок подключения

7

Не выполнен запрос к базе по объектам

X

X

8

Не получен ответ на запрос к базе по объектов

X

X

9

Не открылась база для объектов

X

X

10

Нет доступа к базе данных по объектам

X

X

11

Потребитель отключен по обратному

X

12

Потребитель отключен по подающему

X

13

Нельзя ограничивать расход на подпитку сразу на всех источниках

14

Не записан ответ

15

Не задан ни один источник с неограниченной подпиткой

16

Суммарный расход по всем видам нагрузок потребителя равен 0

17

Не найдены данные в справочнике по насосу

X

X

18

Потребитель отключен

X

19

Узел отключен

X

20

В базе не найдено поле

X

X

21

В данный узел один участок должен входить, другой - выходить

X

22

Задавило насос

X

23

ЦТП не на тупиковой группе

X

24

Задавило источник

X

25

Подпитка на источнике невозможна

X

26

В группе за ЦТП отсутствуют потребители

X

27

Регулятор может быть связан только с одним вспомогательным участком

X

28

Регулятор может быть соединен вспомогательным участком только с простым узлом

X

29

Между регулятором и узлом наблюдения имеются ответвления

X

30

В данный ЦТП должен входить один основной участок и выходить один основной и один вспомогательный

X

31

Вспомогательный участок от ЦТП должен соединяться с простым узлом

X

32

В сеть ГВС ЦТП включены потребители с недопустимыми схемами присоединения

X

33

В сеть ГВС ЦТП не включен ни один потребитель

X

34

В сеть ГВС ЦТП включены недопустимые типы узлов

X

35

Неверная схема присоединения в сети ЦТП с узлом смешения

X

36

Неверная схема присоединения в сети ГВС

X

37

К ЦТП с групповым элеватором подключены потребители с элеваторами

X

38

Напор во втором контуре меньше минимально необходимого

X

X

X

X

39

При заданном напоре в обратнике после ЦТП не хватает напора

X

X

X

X

40

При заданном располагаемом напоре после ЦТП не хватает напора

X

X

X

X

41

Температура на входе первого контура меньше или равна температуре на входе второго контура

X

42

Температура на выходе второго контура меньше или равна температуре на входе второго контура

X

43

Температура на входе первого контура меньше температуры на выходе второго контура

X

44

Не выбран ни один источник для расчета

200

Отсутствует лицензия на использование ZuluNetTools совместно с ZuluThermo

601

Участок не имеет узла

X

602

Обобщенный потребитель с фиксированным расходом после ЦТП

X

603

Потребитель выключен

X

604

Участок с разделителем зон статического давления находится в кольце. Игнорируем разделитель

X

605

Нагрузка на ГВС после группового узла смешения

X

606

Сопло элеватора меньше минимального. Узел не налажен

X

X

607

Предупреждение расчета потокораспределения

X

X

608

Располагаемый напор 2 контура ГВС меньше необходимого

X

X

609

Дросселирующий узел имеет неверное количество участков. Считаем простым узлом

X

610

Группа от дросселирующего узла содержит недопустимые типы. Считаем простым узлом

X

611

Дросселирующий узел не на тупиковой группе. Считаем простым узлом

X

612

В дросселирующий узел один участок должен втекать, другой - вытекать. Считаем простым узлом

X

613

В дросселируемой группе отсутствуют потребители. Считаем простым узлом

X

614

У ряда ЦТП недостаточен располагаемый напор 2 контура ГВС. Расчет остановлен

X

615

Температура на потребителе ниже 10 градусов. Расчет остановлен

X

616

Расход воды на ГВС из обратного трубопровода превышает расход воды на систему отопления

X

X

617

Вода на ГВС поступает и по подающему и по обратному трубопроводу. Узел не налажен

X

X

618

Количество шайб на подающем трубопроводе на СО больше 3

X

X

X

619

Количество шайб на обратном трубопроводе на СО больше 3

X

X

X

620

Опрокидывание циркуляции. Недостаточно напора на потребителе!

X

X

621

Недостаточно напора на потребителе!

X

X

X

622

Не сходится баланс!

X

623

Количество шайб на систему вентиляции больше 3

X

X

X

624

Наладка потребителя произведена при отключенной верхней ступени

X

X

625

Расход на систему отопления увеличен по отношению к расчетному

X

X

X

626

Тепловой баланс между источниками и потребителями может не сойтись, т.к. не все потребители налажены

627

Температура на потребителе ниже 0 градусов. Расчет остановлен

X

X

628

Вода на потребитель поступает и по подающему и по обратному трубопроводу. Расчет узла будет выполнен не корректно

X

X

629

Температура теплоносителя после системы вентиляции меньше 10 градусов!

X

X

630

Система вентиляции отключена из-за возможности замерзания теплоносителя!

X

X

631

Не подобрать сопло элеватора. Ставим минимальный

X

X

632

Не подобрать сопло элеватора. Ставим максимальный

X

X

801

Не записать результат в базу : не найдено поле

X

X

802

Не записать результат в базу: у поля неверный тип

X

X